Platform Exports

Incident Report for Playwaze

Resolved

This incident has been resolved.
Posted Apr 18, 2025 - 16:45 UTC

Identified

The team have identified export issues affecting many admins across the system and we're working diligently to restore this functionality.
Posted Apr 17, 2025 - 10:53 UTC
This incident affected: Playwaze Platform.